• Members 7 posts
    Aug. 28, 2019, 4:58 p.m.

    I've entered my measurements and got to the "create a sweater" page. I'm using my android phone to browse with chrome.

    I can use the drop downs but when it comes to the text fields, I tap them and the cursor doesn't go in and I can't use the virtual keyboard in them so I can't enter text. However, if then I press the button to proceed to the next page, it'll tell me I haven't entered those fields and put my cursor there so I can type in one field. I still can't enter the next field by tapping.

  • Members 7 posts
    Aug. 28, 2019, 5:52 p.m.

    Oh and a suggestion for this page is to have metric as well as US needle size. I guess not a priority if you're intending it for a US audience

  • Aug. 28, 2019, 7:23 p.m.

    Oh dear, I'm not sure what to do about this. They are just normal text input fields so I have no idea why they would not work on your phone. Unfortunately I don't have an Android phone to try it on. Can you try it on some other device?

    Phrancko

  • Aug. 28, 2019, 7:26 p.m.

    I can do that. Thanks for the suggestion.

    And it reminds me, I need to say the measurements are intended to be input in inches. I haven't tried the pattern in centimeters. I have no idea if that would work. But maybe if the gauge was in centimeters also, then it just might work. Which did you use? Inches or centimeters?

    The intent is for an English-speaking audience, not necessarily American, but of course that is what I am most familiar with and what all my testing was assuming.

  • Aug. 29, 2019, 3:11 p.m.

    I have now added metric sizes to all the needle descriptions, in both the dropdown for choosing and also in the pattern materials.

    Unfortunately, testing showed that all measurement must be in inches currently. It is a bigger problem than I realized to accept measurements and gauge in centimeters and then produce the proper pattern. I will be able to do that in the future, but since it is a large task, it will have to wait. I definitely do not want to shut out the world of metric users though. So it will be high on my priority list of future enhancements.

    Thanks for the suggestions. And I apologize for my insensitivity to the global community of knitters!

    Phrancko

  • Members 7 posts
    Aug. 29, 2019, 6:22 p.m.

    Regarding entering measurements in inches, I think that's fine because in your tooltip it says to do it in inches. For some reason I know the garment industry still uses inches as well as cm here (Australia) so I think most people would be ok with that. I know 10cm is 4 inches - that's what I use for my gauge swatch so that's an easy one to enter.

  • Members 7 posts
    Aug. 29, 2019, 6:34 p.m.

    I tried this on my computer and it works. Not sure why entering measurements was ok on my phone but not creating a sweater. I will test again on my phone when I get a chance

  • Aug. 29, 2019, 7:12 p.m.

    That's really good to know. Thanks for telling me. I'll postpone the task of taking all measurements in inches in that case.

    I'm glad the needle sizes in mm was an easy, quick fix.

    Phrancko